Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.

Noob in dire need of help

Last updated on 10 years ago
G
groaaarNewbie
Posted 10 years ago
Hello all :)

I have ordered a new laptop for linux mint, so I can finally dedicate my Sony Vaio SVE1111 to Icaros.

I downloaded the archive on my main comp (Win7 64bits), Then I uncompressed the iso, ran the virtual machine batch file.

It took 30 seconds for Icaros 2.0.1 to load.

Out of excitement, I wanted to install the distrib on a 8Gb USB memory stick with an empty FAT32 partition, as I don't have any physical DVD drive.

So what happened :
1. First try :
I clicked "install aros".
I selected the USB drive, chose disk wipe, and got a message "Aros is now ready to install, click to reboot".
Reading the manual, rebooting from "hard disk" was supposed to take a few seconds. One CPU Core stayed blocked at 100% for 20 minutes. So I think something went wrong.
2. Second try.
Deleted the folder, uncompressed the archive.
Started the VM machine again, Icaros booted like a charm.
Now the USB won't be wiped anymore, I get an error saying partition can't be created. This is rather annoying.

Would it be possible to give me a step by step, idiot-proof way of doing things ? I started to read the joined manual but I am not finding much relevant information, and I am balding enough already these days ;)

Thanks in advance !

*Edit*
It seems that I am not getting an error when selecting the "Use any Aros existing partition" yet. But I have to enter a drive indentifier, and I don' t know what to do. I am not really eager to delete a windows partition. Is there a way to identify my USB key, or the "virtual hdd" ?
Edited by groaaar on 12-01-2015 18:09, 10 years ago
G
groaaarNewbie
Posted 10 years ago
Hello again !
I could borrow an external dvd burner, and did burn the iso.
Now I am getting this problem :
http://aros-exec....ic_id=7530
The workaround explained in this topic isn't accessible to me, as I don't have an IDE Legacy option in the computer's bios.

Do I have to understand that I won't be able to install Icaros on my laptop ?

Please help ! Thanks
M
magoriumSoftware Dev
Posted 10 years ago
Hi groaaar,

I am afraid the information you have given so far is working a little confusing to me (and seems contradicting).

So if you are able to take a deep breath and take a little step back, then it would be appreciated :)

First let us start with your aim/goal.

Did i understand correctly that you wanted to install Icaros desktop on your Sony Vaio SVE1111 machine ?

Did i understand correctly that it is your intention to install Icaros on that machine as only OS ? or is Icaros suppose to run besides windows or linux (dual boot) ?

Did i understand correctly that you do not have physical CD-rom drive and therefor wanted to use the usb pen-drive installation route, but that you are afraid you will 'hurt' the computer you ran the installation on ? (and is that another computer ?)

It would be appreciated if you could share what you are trying to accomplish on what computer exactly, in order to be able to help you better.

fwiw: the error you are seeing (insert bootable media) isn't related to the legacy IDE option in the BIOS as you are using an external (and therefor i assume usb cd-rom drive).

More likely the error you are confronted with is due to having conflicting attached usb hardware or having atteched the the cd-rom player on the same header as f.e. your usb-pendrive or keyboard/mouse. AROS ican be very picky with certain USB devices, so better make sure you only have your cd-rom drive attached and nothing else (e.g. try to remove external mouse/keyboard and avoid using any hubs).
G
groaaarNewbie
Posted 10 years ago
Hello Magorium,

Sorry for being unclear.

Firstly, I tried to follow the procedure on my desktop machine, in order to create a USB stick. That didn't work.
Moreover, this computer has 4 sata drives inside, with important data on them, so I didn't dare fiddling too much, because I didn't want to lose data in case of a wrong doing.

Then, today, I could borrow a USB dvd burner. So I burned the iso contained in the Icaros_2.0.1 archive, and plugged the DVD drive to a USB port on my laptop.

I wanted to install Icarios as the only OS on the Sony Vaio, so there, I didn't matter if the hard drive got wiped. It's a clean 500Gb sata drive.

I was very pleased to see the computer boot from the dvd drive. But instead of seeing the desktop, I got the error screen depicted on the link I provided.
Sadly, in my Vaio's BIOS, I can't set the sata controller to "IDE Legacy".

While trying with the DVD, the only other USB device that was inserted was the mouse. And it was obviously making a mess.

It's working now. Thanks for the help !

Meanwhile, since I have a very old Gericom laptop (from 2003), I tried on it and it installed Icaros properly.
I really like what I am seeing so far, even if it's a bit complicated to figure stuff out. The last time I touched an Amiga was in 1995, and it was an Amiga 500. But I'm willing to make the effort, as with lots of other people, I have always dreamt, since 1990, to have a portable Amiga :)
Edited by groaaar on 13-01-2015 14:55, 10 years ago
G
groaaarNewbie
Posted 10 years ago
Ok I think things are getting solved step by step.

Icaros doesn't seem to be able to connect to the internet, as I'm getting "host not found" errors.

I'm on a cable router, meaning a computer's IP will be 192.168.0.24 for instance, and the router will be managing the rest.

How do I configure Icaros, in order to setup a connection ?

Thanks

*Edit :
I have found the AROS/prefs/network, entered the DNS ips (google's : 8.8.8.8 & 8.8.4.4), I assigned a local IP (192.168.0.24), but I keep getting the "could not resolve host name" error.

Gosh I feel dumb since I have installed that OS ;)
Edited by groaaar on 13-01-2015 15:46, 10 years ago
M
magoriumSoftware Dev
Posted 10 years ago
Thank you for having taking the time to report back and having mentioned what your culrpti was :thumbsup:

Your situation of having amiga experience but haven't touched the OS for a while is a situation that seems very common ;)

Good that you were able to figure it out. Because AROS runs on modern hardware, things are a bit different in comparison to a classic amiga machine.

In that regards the learning curve might be a bit steep, and requires a bit of investment. On the other hand, once you have setup things to your likings and work for you, then you do not really need to have another look at the configuration settings.

Seeing your desktop specification i would assume it is a fast computer. In case you want to experiment with icaros on your laptop machine, then you could always opt for running Icaros inside a virtual machine on your desktop machine and test things there first.

Yeah, most people have dreamed about an Amiga laptop... shame that it never surfaced :/

Oh and sorry. Usually i say hello and welcome to these forums. so hereby :)

Hopefully you'll enjoy AROS/Icaros, and feel free to ask in case you get stuck.

It is advisable to read the manual as it covers most topics, but things are not always clear or you might wonder about certain topics anyways. Also there can be hardware that is not very compliant with AROS and can cause issues.

Greetings,
Ron.
You can view all discussion threads in this forum.
You cannot start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
Moderator: Administrator
Users who participated in discussion: magorium, groaaar
Sign In
Not a member yet? Click here to register.
Forgot Password?
Users Online Now
Guests Online 4
Members Online 0

Total Members: 242
Newest Member: JumpingKiwi
Member Polls
Should AROSWorld continue with AROS-Exec files (SMF based)?
Yes44 %
44% [12 Votes]
No26 %
26% [7 Votes]
Not sure30 %
30% [8 Votes]