Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.

Building older versions of Aros

Last updated on 8 months ago
D
d0wzJunior Member
Posted 8 months ago
This is low priority.

I've been building "older" Aros versions, from source. Just sort of wrapping my head around the history of changes.

I noticed around 3-1-19 GMA video was still supported natively (in my test machine's case i915). By 5-1-19 it was dropped; Mesa was upgraded from 19.x to 20.x. It is probably safe to assume that native support never returned, for these older GPUs, as vesa still works fine.

Not too long, after 5-1-19 I ran into trouble, completing successful builds. Loadseg (-lloadseg) isn't found by the Aros linker, while trying to build something (maybe libloadseg.a didn't build?) partition.library depends on. This problem persists all the way up to early 2021 builds. As you can tell, I haven't really looked into it yet.

I eventually realized that INSTALL.md appeared, in the source directory. Looking in to rebuild.sh I discovered, per instruction, building via x86_64 was the only thing the script really supported. My host was 32bit. Previously, I was using configure/make/make distfiles. Thinking that this could have been my issue, I moved to a modern machine/Linux. Running the script informed me that the compiler needed a patch, please re-install and run configure. Kind of a dead end. Since, I was already all set up, I ran configure --target=pc-i386/make. Ended up with the same error as on the 32bit system.

I looked through the, date appropriate, issues/bugs and found nothing about this issue. It would be pretty lame of me to, expect any kind of actual support on these older builds. I know I'm kinda on my own here. I was just wondering if anyone had ever ran into this before?
D
deadwoodAROS Dev
Posted 8 months ago
Hi there,

I should be able to help you, but please first let me know which repository and which branch are you trying to build?
D
d0wzJunior Member
Posted 8 months ago
It is ABIv0.

6-23-19
https://github.com/deadw00d/AROS/tree/c6d72c1763f1df8d66b2737e3005620168437f19

Trying to make partition.library ends as -lloadseg is not found. Indeed, libloadseg.a isn't there.

Hmm, just noticed that there is a 6-23-19 commit "Rework Loadseg".

If nothing obvious comes to mind, I could try building from 6-22-19. That would at least pinpoint my issue a little. It is just strange, as so many newer builds gave me the same issue. But, it had to have been building fine, elsewhere. Oh well. Its late for me, gonna hit the hay.
D
deadwoodAROS Dev
Posted 8 months ago
Ok, I understand.

Well, the story with alt-abiv0 is... complicated. That branch in reality is a set of patches re-based over master for every release. What this means is that you cannot go back at any point in time, because you are actually going into history of master (which is not ABIv0-compatible). What makes alt-abiv0 ABIv0 compatible is a set of ~250 patches at top of history,

Having said that, there are ways to go back in time - each time a release is made, a new tag is created:
https://github.co.../AROS/tags

Look for tags with ABIv0_ prefix and this way you can get older versions.
You can view all discussion threads in this forum.
You cannot start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You cannot download attachments in this forum.
Users who participated in discussion: deadwood, d0wz
Sign In
Not a member yet? Click here to register.
Forgot Password?
Users Online Now
Guests Online 6
Members Online 0

Total Members: 242
Newest Member: JumpingKiwi
Member Polls
Should AROSWorld continue with AROS-Exec files (SMF based)?
Yes44 %
44% [12 Votes]
No26 %
26% [7 Votes]
Not sure30 %
30% [8 Votes]