Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.

USB Gamepad not available after reboot

Last updated on 2 months ago
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 2 months ago
Thanks, just to test I tried your poseidon prefs and it doesn't work.

For the Mouse the problem seems to be different is more complicated, since on some PCs it disappears in VESA Graphics mode and on others in Native Mode.
F
FaroxMember
Posted 2 months ago
Hi and sorry for late reply...
Attached is my poseidon.prefs, don't think will be usefull for anyone, but maybe only for testing.

@AMIGASYSTEM
maybe USB wifi mouse need a specific driver ? What Trident says in the log about it ?
Farox attached the following file:
poseidonprefs.zip [800Bytes / 119 Downloads]
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 2 months ago
@deadwood
With the USB Wifi Mouse the saving of Trident seems not to work !
D
deadwoodAROS Dev
Posted 2 months ago
@Farox

I will keep the bug opened for now. The base build does not have this file in SYS, so the problem will be there as well. I'd like to understand why this is happening and whethere it can be solved without saving prefs. I'll add your comments as a workaround.

@AMIGASYSTEM

That bug is actually more complex. In my scenario it the other way around. I get mouse pointer when bootin in VESA but don't get it when booting with nVidia driver. Note that mouse is actually working: you can click things, you just don't see the mouse pointer.
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 2 months ago
As a verification you should try a Mouse or other USB peripheral other than a GamePad, if you attach here the save file I can test it with my Mouse !
F
FaroxMember
Posted 2 months ago

AMIGASYSTEM wrote:

@AMIGASYSTEM - @Farox
Thanks Farox, that save you made works with your GamePad , but it will not work for the various types of Mouse or other USB peripherals, practically all users would have to make the save to work !


In my test when i saved the prefs i was using only one type of gamepad. Next i power off and connected another pad and when i poer on the PC it worked without any extra actions.
So i think the prefs ( a default prefs) need to be saved for correct operations of poseidon.
But i'm not an expert so maybe we need to wait for the opinion of Deadwood.
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 2 months ago
@Farox
Thanks Farox, The save you made works with your GamePad, it may not work with various types of Mouse or other USB peripherals, practically all users would have to do the same thing to work !

In my opinion the Bug needs to be fixed anyway, for the reasons I am reporting to deadwood (see below)

About the Trident icon, it has always been there on AROS One, probably when I decided to replace it with a new icon, I forgot to copy it in the on the new AROS One that was under construction.


@deadwood
Regarding the Pointer disappearing if it was inserted before booting the system, I found that this only happens if you boot AROS in VESA mode, however if you boot AROS in Native mode (Video Card supported) the Pointer does not disappear.

Tested on both AcerOne z5 and Dell Inspiron Mini 910 !
F
FaroxMember
Posted 2 months ago
I think found why USB Pad/Joy (and maybe others USB ?) where not correctly used after a reboot (at least on AROS One where i tested), poseidon.prefs was missing in RAM:ENV/SYS directory.

I solved opening "trident" panel and then saving prefs, then copyed over to "AROS Live Drive:prefs/ENV-archive/SYS" so when you reboot the file "poseidon.prefs" is copyed in RAM:ENV/SYS directory and used by the system.

Now the gamepad is used every time without unplug/replug in.

@AMIGASYSTEM i think will be usefull also to create an icon for the "trident" panel and make a link to "Prefs" Menu in AROS One (other then adding a default poseidon.prefs file).

@deadwood i think we could also close this issue on github.
Edited by Farox on 07-05-2024 16:38, 2 months ago
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 2 months ago
Could be the same problem as bug #126 about USB Mouse not working if it stays plugged in, Pointer disappearing
D
deadwoodAROS Dev
Posted 2 months ago
Ok, thanks for confirmation
F
FaroxMember
Posted 2 months ago
Just tested with 2 other devices, and have the same behaviour, they works under AROS but we need to unplug/plug every time.
They are Thrustmaster Run&Drive and SPEEDLINK Competition Pro USB.

Thanks
Farox attached the following image:
competitionpro.jpg thrustmastrundrive.jpg
R
retrofazaJunior Member
Posted 2 months ago
I have an 8bitdo SN30Pro pad and it works under AROS in DINPUT mode. It behaves the same as the pad described by Farox.
D
deadwoodAROS Dev
Posted 2 months ago
Ok, added a bug report here: https://github.com/deadwood2/AROS/issues/141

Do you have another gamepad to test whethere this behavior is same for all pads or just this one?
F
FaroxMember
Posted 2 months ago

deadwood wrote:

@deadwood - Does unplugging and pluggin again solve the proble or the pad is "broken" until computer reset?


Yes unplugging and pluggin in again made the pad available for the game, but is really uncomfortable.

Thanks
Edited by Farox on 30-04-2024 17:02, 2 months ago
D
deadwoodAROS Dev
Posted 2 months ago
Does unplugging and pluggin again solve the proble or the pad is "broken" until computer reset?
F
FaroxMember
Posted 2 months ago
Hello
I tested one of my game (MBX) on AROS with the use of gamepad an USB pad (The Gamepad of A500Mini), and its working good with the game.
The problem arise when i left the pad attached to PC and power off and later power on the machine the pad is listed on trident panel but is not detected by the game.
I attach the screen shot of the trident panel.
Edited by Farox on 30-04-2024 09:40, 2 months ago
Farox attached the following image:
snap-20240429-001_1.jpg snap-20240429-003_1.jpg
You can view all discussion threads in this forum.
You cannot start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
Moderator: Administrator
Users who participated in discussion: deadwood, AMIGASYSTEM, retrofaza, Farox
Sign In
Not a member yet? Click here to register.
Forgot Password?
Users Online Now
Guests Online 8
Members Online 0

Total Members: 239
Newest Member: MAuAGA
Member Polls
Should AROSWorld continue with AROS-Exec files (SMF based)?
Yes44 %
44% [12 Votes]
No26 %
26% [7 Votes]
Not sure30 %
30% [8 Votes]