Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.

Icaros installation on Dell Notebook - HDD empty prevent installation from CD

Last updated on 3 months ago
L
lion-tNewbie
Posted 3 months ago
Hi Team,

I'm a newbie with Icaros and tried today to install Icaros on a Dell notebook and stocked where the installation (write data to HDD) should start because the HDD won't be identified.
I followed the instructions documented in the Icaros handbook.
https://www.icaro...manual.pdf

My Hardware: DELL Studio 1737, Intel Core (TM) 2 Duo T6400 2GHz, 3GB RAM, 300GB HDD, ATI Mobility Radeon HD 3650, Windows 10 OS installed.

In details:
1. Downloaded ISO Icaros Live PC i386 32bit Version 2.3.0 and burned it on a CD
2. Start installation with CD and followed instruction from handbook in most cases used the default setting
3. In the installation wizzard I used the "Wipe disk" option, rebooted and then choose on same step "use existing AROS partition"
4. As dedected drive it was shown an IDE drive with device name ata.device Unit 0 and system partition DH0, filesystem SFS
5. In the installation options I choose all checkboxes (incl. language option)
6. regarding Size I choose default option (means all available space) in assumption that the existing WindowsOS will be deleted
7. In the wizzard step 'choose on which partition it should be installed' I used DH0 as destination and DH1 as work partition. Furthermore I enabled both checkboxes for formatting the partitions. and enable both checkboxes for Workpartition and Extra Developer files

No we come to the wizzard window GRUB setting.

Here the issue --> no device will be displayed in the box. In the documentation was mentioned ahci.device, in my case how I mentioned earlier it was ata.device. I tried both with out success.
If I clicked on the Process/start button in run into endless popup window scenario asking for drive.


Next I restarted the notebook from CD and checked with the HDToolBox the partitions:
The tool mentioned four partitions (0,1,2,3) on ahci.device / Unit 0

Partition 0 172 MB
Partition 1 10 GB
Partition 2 287 GB (main HDD)
Partition 3 500 MB


Partition 2 is active.
For all four the bootable and automount option = no

I restarted the notebook and boot from HDD and Windows started. There I checked and noticed 2 partitions. C (main), D (Recovery)

Now I don't know what I'm doing wrong. Could somebody guide me or have an idea what I can do more?

I think its related to the partitions and maybe limitation of max. diskspace - AROS SFS system can't handle partitions bigger than 128 GB.

So Should I choose another file system for using full 300 GB HDD or should a split the 300 GB HDD into multiple parts e.g. 128 GB (Aros file system) + 172 GB.


Thank you for every help.

Cheers,
Lion-T
A
Amiwell79Distro Maintainer
Posted 3 months ago
welcomeSmile

have you checked in the computer bios if the hard disk is enabled as ata device always if there is the option
A
Amiwell79Distro Maintainer
Posted 3 months ago
ahci.device is not supported for icaros installation
L
lion-tNewbie
Posted 3 months ago
Hi,

thanks for your response. I was not aware of that and indeed in the Bios was ahci enabled.
I changed it into IDE and with that the device was shown in the selectbox.

But after starting the installation the popup window still displayed with message "Please insert volume "DH1" in any drive.
DH1 I selected as work partition in the wizzard window.
I cannot cancel the popup and if I click on the retry button the popup came up again.

What can I do?

Thx again.
A
Amiwell79Distro Maintainer
Posted 3 months ago
delete all disk partitions and restart icaros and installation
Edited by Amiwell79 on 15-02-2024 12:16, 3 months ago
Amiwell79 attached the following image:
installaros.jpeg
A
Amiwell79Distro Maintainer
Posted 3 months ago
they are working to solve the achi.device problem but in the latest distributions icaros is obsolete
L
lion-tNewbie
Posted 3 months ago
Ok, I used the HDToolBox and deleted the one existing partition. Will restart with Icaros and installation. Finger-crossed that it will work.
A
Amiwell79Distro Maintainer
Posted 3 months ago
OK create two partitions of 100 gb each
Amiwell79 attached the following image:
installaros_1.jpeg
L
lion-tNewbie
Posted 3 months ago
@Amiwell79: What you mean with Icaros is obsolete?
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 3 months ago
Are you installing AROS as a DualBoot with Windows?

Have you partitioned the hard disk from InstallAROS?
L
lion-tNewbie
Posted 3 months ago
@AMIGASYSTEM: No I dont use dualBoot. I dont needthe window10 anymore. Windows10 was installed on the HDD. I boot icaros from CD directly with expectation that all windows stuff will be deleted / formatted inclusive new partitions will be created for Icaros.

And 'yes' initially I used InstallAROS and follow the wizzard how it was described in the handbook.
After changing ahci into IDE on BIOS level the wizzard was able to idnetify the ata.device in the last window before the installation should start. But then if I started the installation the windows with DH1 poped up.
Again I choosed DH1 as working partition in the wizzard window before.


I want to use the notebook only for Icaros without any Windows anymore.

BR,
Edited by lion-t on 15-02-2024 12:31, 3 months ago
A
Amiwell79Distro Maintainer
Posted 3 months ago
[quote name=lion-t post=4198]@lion-t - @Amiwell79: What you mean with Icaros is obsolete?[/quote]

yes it has not been updated for a long time now there are two distributions my tiny aros with dopus5 magellan and amigasystem's aros one with wanderer
Edited by Amiwell79 on 15-02-2024 12:29, 3 months ago
L
lion-tNewbie
Posted 3 months ago
never heard from these two versions. I want to have a real hardware device with an Amiga OS installed.
No emulator like winUAE or Virtual Machine running under Windows.

So I found Icaros.

Can you share links to the two versions you mentioned.
- aros with dopus5 magellan
- amigasystem's aros one with wanderer

Thanks.
A
Amiwell79Distro Maintainer
Posted 3 months ago
Tiny Aros

https:/tinyaros.flazio.com/

Aros One

https://sites.goo...sone?pli=1
A
Amiwell79Distro Maintainer
Posted 3 months ago
as for tiny aros you have to download the iso and the system files from my site which you will put on a usb key, install the iso afterwards insert your usb key with the system files and copy them to dh0: then proceed with a reboot, aros one has a disk image which you can use rufus to copy it to a stick and make it bootable and an iso to burn
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 3 months ago
lion-t, if you decide to install AROS One, in addition to the ISO in my link you will also find a USB Image to burn to Pendrive, very convenient for quick installations.

Regarding installAROS, it is important that you first initialize the Hardisk by deleting the Windows bootloader, you can do this from InstallAROS by first choosing "Wipe Disk", after reboot choose "use existing AROS partitions" and install AROS on one or two partitions, on my site you can find many comprehensive videos on how to install AROS One.

Install AROS One x86 Two Partition (DHO and DH1)
https://youtu.be/...

Homesite AROS One
https://sites.goo...sone?pli=1
A
Amiwell79Distro Maintainer
Posted 3 months ago
if you install tiny aros include everything on the system partition as it does not take up much space, if you want to create your own work partition you can do so but use it for your data not for system data, extras etc..
You can view all discussion threads in this forum.
You cannot start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
Moderator: Administrator
Users who participated in discussion: AMIGASYSTEM, Amiwell79, lion-t
Sign In
Not a member yet? Click here to register.
Forgot Password?
Users Online Now
Guests Online 19
Members Online 0

Total Members: 231
Newest Member: JohDoe
Member Polls
Should AROSWorld continue with AROS-Exec files (SMF based)?
Yes44 %
44% [12 Votes]
No26 %
26% [7 Votes]
Not sure30 %
30% [8 Votes]