Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.

Bars&Pipes 1.0 is Available

Last updated on 1 month ago
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 3 months ago
Can you share your system (create a zip) it might help us to see if it is a hardware problem !
A
Amiwell79Distro Maintainer
Posted 3 months ago
My system is Tiny Aros
Signature: Tiny Aros OS
https://www.tinyaros.it
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 3 months ago
Tested your TinyAROS is you get the same Guru, see screenshot
You don't get Guru maybe because you have supported Hardware, or you didn't copy all the files in the SystemStuf folder, that's why I was asking the system you are using.


--- Italiano ---

Testato il tuo TinyAROS è si ottiene lo stesso Guru, vedi screenshot
Tu non hai Guru forse perchè hai un Hardware supportato, oppure non hai copiato tutti i file della cartella SystemStuf, ecco perchè occorreva il sistema che stai utilizzando.
A
Amiwell79Distro Maintainer
Posted 3 months ago
I already had the necessary installed to run the programme I did not install the fonts and catalogues
J
Jeff1138Junior Member
Posted 3 months ago
Hi,

Great that we can verify the same issue
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 3 months ago
@ Amiwell

Even without Fonts TinyAROS goes in Guru, if you share your system we could check the differences.

Question just avii small requests appear !

Question as soon as you run Bars&Pipes small requests appear !


--- Italiano --

Anche senza Fonts TinyAROS va in Guru, se condividi il tuo sistema potremmo verificare le differenze.

Domanda appena esegui Bars&Pipes appaiono dei piccoli request !
A
Amiwell79Distro Maintainer
Posted 3 months ago
alfred wrote me this:

Try this:
-open a shell
-cd to the BarsnPipes directory
-start BarsnPipes with:
BarsnPipes debug

Normally any debug information is now printed.
In BarsnPipes, drag the icon from the Quantize tool into the pipeline and drop it there.
Double-click this icon in the pipeline. The window of the icon is opened.
Leave the window open and click in the track window (title becomes red).
Press the right AMIGA key and Q or select Quit in the menu.
Requester -> Save? -> Press No
If everything runs normally, a few debug messages will appear in the shell-window:
" ..."
"get entry for cowlist ..."
at the end:
"freelocalestrings
Done"

If this is not the case, please write me the last debug message.
A
Amiwell79Distro Maintainer
Posted 3 months ago
amigasystem should I zipper the entire system folder?
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 3 months ago

Amiwell79 wrote:

@Amiwell79 - alfred wrote me this:

Try this:
-open a shell
-cd to the BarsnPipes directory
-start BarsnPipes with:
BarsnPipes debug

After this step the Guru already appears, the debug data who should analyze it? I think only the developer can do it !

Quote


In BarsnPipes, drag the icon from the Quantize tool into the pipeline and drop it there.
Double-click this icon in the pipeline. age


Where is the "Quantize" icon located ? what is "pipeline" ?

If possible ask alfred which Distribution he used for Testing !
A
Amiwell79Distro Maintainer
Posted 3 months ago
My Tiny Aros Archive

https://drive.goo...sp=sharing
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 3 months ago
Amiwell, you don't have the Guru because on your TinyAROS the folder "USB" (Classes/USB ) is not detected by Operating System, see screenshot

The .class files are there in the USB folder, but TinyAROS does not detect them.

Also on my AROS One if I disable the "USB" Folder I no longer have the Guru, this happens because Bars&Pipes does not detect the USB Drivers !!!


--- Italiano ---

Amiwell, tu non hai il Guru perchè sul tuo TinyAROS la cartella "USB" (Classes/USB) non viene rilevata da Sistema Operativo, vedi screenshot

I file .class ci sono nella cartella USB, ma il TinyAROS non li rileva.

Anche sul mio AROS One se disattivo la Cartella "USB" non ho più il Guru, questo accade perchè Bars&Pipes non rileva i Driver USB !!!
AMIGASYSTEM attached the following image:
tiny_1.jpg
A
Amiwell79Distro Maintainer
Posted 3 months ago
do not have this error on my system Bars&Pipes works and also all USB class
Edited by Amiwell79 on 16-03-2024 11:56, 3 months ago
D
deadwoodAROS Dev
Posted 3 months ago
Hi,

I tried running Bars&Pipes that is currently in upload queue on Linux-hosted AROS. It seels linux-hosted has a host-midi driver so that it should work.

The problem is that Bars&Pipes crashes immediately at start with following disassembly:


Dump of assembler code for function startfunctions:
 0xe8f8678c <+0>:   push %ebp
 0xe8f8678d <+1>:   mov %esp,%ebp
 0xe8f8678f <+3>:   push %edi
 0xe8f86790 <+4>:   sub $0x8,%esp
 0xe8f86793 <+7>:   mov $0xe9170760,%edx
 0xe8f86798 <+12>:   mov $0x225,%ecx
 0xe8f8679d <+17>:   mov $0x0,%eax
 0xe8f867a2 <+22>:   mov %edx,%edi
 0xe8f867a4 <+24>:   rep stos %eax,%es:(%edi)
=> 0xe8f867a6 <+26>:   mov 0x4,%eax



It looks like reading something from address 0x4, which on Amiga is I think SysBase, but this is not the case for AROS. Or AROS SysBase is automatically provided and there is no need to "read $4". Can you ask the author whether what I wrote here is true and if so to modify Bars&Pipes not to read from address 4?
A
Amiwell79Distro Maintainer
Posted 3 months ago
ok i wrote
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 3 months ago

Amiwell79 wrote:

@Amiwell79 - do not have this error on my system Bars&Pipes works and also all USB class

When you start Bars&Pipes, do you get the message requests ? if not do you get them the USB classes are not active !

Try deadwood's reference ISO without TinyAROS where the USB Crates are active and you will see that you get the error, as mentioned by deadwood

--- Italiano ---

Quando avii Bars&Pipes, ricevi i request di messaggi? se non li ricevi le classes USB non sono attive !

Prova la ISO di riferimento di deadwood senza TinyAROS dove le Casse USB sono attive e vedrai che ricevi l'errore, come accennato da deadwood
A
Amiwell79Distro Maintainer
Posted 3 months ago
I receive requests
----
si li ricevo i request
Edited by Amiwell79 on 16-03-2024 18:33, 3 months ago
A
Amiwell79Distro Maintainer
Posted 3 months ago
I downloaded usbmidi from Archives
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 3 months ago

Amiwell79 wrote:

@Amiwell79 - I receive requests

What you see in my screenshot ?

--- Italiano ---

Quello che vedi nel mio screenshot ?
AMIGASYSTEM attached the following image:
bp.jpg
A
Amiwell79Distro Maintainer
Posted 3 months ago
yes
A
Amiwell79Distro Maintainer
Posted 3 months ago
I reinstalled Tiny Aros B&P works, the problem lies in the systemstuff, I installed the drivers, tools and library from the archive which is on aros archivesSmile
Edited by Amiwell79 on 16-03-2024 19:45, 3 months ago
You can view all discussion threads in this forum.
You cannot start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You can download attachments in this forum.
Moderator: Administrator
Users who participated in discussion: aha, deadwood, AMIGASYSTEM, Amiwell79, Jeff1138
Sign In
Not a member yet? Click here to register.
Forgot Password?
Users Online Now
Guests Online 9
Members Online 0

Total Members: 235
Newest Member: pikewerfer
Member Polls
Should AROSWorld continue with AROS-Exec files (SMF based)?
Yes44 %
44% [12 Votes]
No26 %
26% [7 Votes]
Not sure30 %
30% [8 Votes]