Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.

AROS ABIv0 20220318 Development [CLOSED]

Last updated on 4 months ago
deadwoodAROS Dev
Posted 6 months ago
Ok, glad you found a workaround Smile
Posted 6 months ago
JetPac >- It worked well with previous Bulid 17/06/2022

NetBubble>- It worked well with previous Bulid 17/06/2022

On some games I have solved Stack errors by increasing the Stack!

Question: What application do you use to know the correct Stack?

On VICE (Emulator C64) I deleted some binaries that were going into Guru, C64 emulation is guaranteed by other binaries.
deadwoodAROS Dev
Posted 6 months ago
NetBubble -> works for me, you need to set 1024000 stack

JetPac -> the game is broken, it is compiled with SDK from 2009 that had a bug in it and it only worked by luck. I will release a re-compilation.

As for application to use to know correct Stack -> there is no such application. You need to increase stack until you stop getting "Stack went out of limits" Guru.
deadwoodAROS Dev
Posted 6 months ago
Posted 6 months ago
Ok thank you, about the stack i had mentioned it a while ago, on Amiga OS3 there is a small application "StackAttack" that sets the right Stack automatically to run a progrmma.

The StackAttack archive includes the source (ASM), on my OS3.9 it works fine !

deadwoodAROS Dev
Posted 5 months ago
Reading the description, StackAttack does not set the right stack for a given program. It just increases the default stack values that are present in the system for all processes (user and system ones).

On AROS you can change default stack for Shell via Stack command, but we are missing a Prefs program that allows setting default stack for programs started from Wanderer. Right now default stack is 40960 for such programs.
Posted 5 months ago
Ok thanks, in any case with StackAttack I have never received any errors si Stack, without StackAttack on the other hand it often happens that a program requires a higher Stack, on OS3, almost never the low stack does generate a Guru, but only warning requests.
deadwoodAROS Dev
Posted 5 months ago

Can you tell me more or less far are you with testing third party applications? 25%/50%/75%?
Posted 5 months ago
75% I should finish today !
deadwoodAROS Dev
Posted 5 months ago
Thanks Smile
Posted 5 months ago
deadwood, TextEditor.mcc is old, some applications require a more updated version, I had to replace your library with the one distributed on aminet:

deadwoodAROS Dev
Posted 5 months ago
Ok, I understand. At some point these packages will be updated in AROS tree, but not at this point.
Posted 5 months ago
deadwood I finished, if I didn't miss anything, found no problem running all the rest of the Applications present on AROS One 2.4 (c library)
Found only small Stack problem with MPlayer "only" for MPG format, to run I set in Toolypes Icon a Stack of 50,000, all other video formats .MP4, .VOB. .MOV, 3GP, WMV, FLV, VOB, FLI, ASF, FLC no problem with the 8,192 stack.

Also tested new versions of Loview, ProTrekkr and Control Sonos (now also on AROS x86, requested by me from developer)
deadwoodAROS Dev
Posted 5 months ago
Thank you very much AMIGASYSTEM for thourough testing. I will then proceed with making the release.
deadwoodAROS Dev
Posted 5 months ago
Hi All,

The release is now official. Thanks to everyone who participated in testing and made the final release better!

I will start annoucing release on various forums still today. I will also open up a new thread for support related posts. Please don't post any more in this thread.
retrofaza, mmartinka, Argo
Posted 4 months ago

deadwood wrote:

@deadwood - Hello,

Here we go with next iteration. You know the drill ;)

Reference ISO: https://www.axrt.org/download/aros/v0/AROS-20211128-1-pc-i386-boot-iso.zip

First ISO moves us to 20211214 code base. There is only one notable change here, new C library. It's a big change though and essentially requires retesting all software to find out regressions.

Here is D01 ISO: https://axrt.org/development/AROS-20211214-D01-pc-i386-boot-iso.zip

The ISO contains core, contrib and Odyssey re-compiled to use the new C library. Big thanks to terminills for sharing his build machine which speeds up Odyssey build 2.5x times.

If you are integrating this ISO into your distribution and installation (so if you have "old" files), you need to delete some of them. I attach a script that shows which files to delete. Without deleting these files, the test results will be invalid. Note that deleting these files will make old Odyssey to stop loading. Best to keep two installations - reference and new system.

The most visible problems you can encounter after integrating is that some software will stop loading because stdc.library, stdcio.library or posixc.library is missing. Note that only software coming from AROS ISO should be using these libraries. The solution it to update the software with the version on the D01 ISO. If it happens that 3rd party (download from archives) software is reporting need for those libraries, be sure to let me know which.

Have fun :)

AROS ABIv0 20211214-D01 changes:

 Introduce new C library, synchronized with 64-bit AROS (deadwood)
 Allow linux hosted AROS to work under WSL (Kalamatee)


 Functional fixes:
 Wanderer (bugs: #107) (deadwood)
 fat-handler (bugs: #107) (deadwood)

 Stability fixes:

 64-bit/68k/ARM support:

Delete Libs:stdc.library
Delete Libs:stdcio.library
Delete Libs:posixc.library
Delete Libs:jfif.library
Delete Libs:jpeg.library

Delete Development:include/clib/arosc_protos.h
Delete Development:include/clib/posixc_protos.h
Delete Development:include/clib/stdcio_protos.h
Delete Development:include/clib/stdc_protos.h

Delete Development:include/define/arosc.h
Delete Development:include/define/posixc.h
Delete Development:include/define/stdcio.h
Delete Development:include/define/stdc.h

Delete Development:include/inline/arosc.h
Delete Development:include/inline/posixc.h
Delete Development:include/inline/stdcio.h
Delete Development:include/inline/stdc.h

Delete Development:include/libraries/posixc.h
Delete Development:include/libraries/stdcio.h
Delete Development:include/libraries/stdc.h

Delete Development:include/proto/arosc.h
Delete Development:include/proto/posixc.h
Delete Development:include/proto/stdcio.h
Delete Development:include/proto/stdc.h

Delete Development:lib/libarosc.a
Delete Development:lib/libposixc.a
Delete Development:lib/libstdcio.a
Delete Development:lib/libstdc.a

deadwood excuse me a question, I would like confirmation that also on your Build AROS 68x had the same change, that is it was compiled with the new C library, and if there is a Contrib 68k compiled with the C library, thanks
deadwoodAROS Dev
Posted 4 months ago
68k build only ever had the "new" C library. Also I don't remember if I ever made contrib available, but if I did, it also was compiled with "new" C library.

68k build is currently only for testing purposes so, there won't be any specific updates to it at this time.
You can view all discussion threads in this forum.
You cannot start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You cannot download attachments in this forum.
Users who participated in discussion: serk118uk, magorium, deadwood, AMIGASYSTEM, pixie, retrofaza, Amiwell79, miker1264, Gundam
Sign In
Not a member yet? Click here to register.
Forgot Password?
Users Online Now
Guests Online 8
Members Online 0

Total Members: 242
Newest Member: JumpingKiwi
Member Polls
Should AROSWorld continue with AROS-Exec files (SMF based)?
Yes44 %
44% [12 Votes]
No26 %
26% [7 Votes]
Not sure30 %
30% [8 Votes]