Oh no! Where's the JavaScript?
Your Web browser does not have JavaScript enabled or does not support JavaScript. Please enable JavaScript on your Web browser to properly view this Web site, or upgrade to a Web browser that does support JavaScript.

AROS ABIv0 20220318 Development [CLOSED]

Last updated on 2 months ago
A
Amiwell79Distro Maintainer
Posted 6 months ago
there is a game that makes use of the thread.library is Frogatto
A
Amiwell79Distro Maintainer
Posted 6 months ago
you need to understand whether you can do without certain applications
D
deadwoodAROS Dev
Posted 6 months ago
Thanks. I'll review those applications and see what can be done about these problems.
A
Amiwell79Distro Maintainer
Posted 6 months ago
but afterwards there will be a switch to x64
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 6 months ago
With D01 ModExplorer cannot connect, see screenshot !

Aros-archive = ModExplorer
http://archives.a...r_aros.zip
You do not have access to view attachments
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 6 months ago
deadwood, ntfs-handler is read-only, while ntfs3g-handler works both read and write, do you think they are reliable?
On AROS One I have these two filesystems in storage for those who want to use them.
D
deadwoodAROS Dev
Posted 6 months ago
I don't know, I never worked with them.
A
Amiwell79Distro Maintainer
Posted 6 months ago
apart from some software that can be replaced with other similar software i have no problems with everyday use all the best works and i can make a complete list if the problem with the intelGMA driver is fixed i am ready to publish a new version of tiny aros
D
deadwoodAROS Dev
Posted 6 months ago
Can you publish the list of software that does not work you after the migration to new C library?
A
Amiwell79Distro Maintainer
Posted 6 months ago
deadwood have been posted in this thread by amigasystem I don't use them apart from the fact that some are included in my distribution like modexplorer SMBFS and VNC that don't work
D
deadwoodAROS Dev
Posted 6 months ago
Ah, ok - I though you had some more software that AMIGASYSTEM didn't list.
A
Amiwell79Distro Maintainer
Posted 6 months ago

AMIGASYSTEM wrote:

@AMIGASYSTEM - @deadwood

I finished checking AROS One for applications using the libraries: stdc.library, stdcio.library, posixc.library, jfif.library, jpeg.library, Thread.library :

With some of these I solved by using the probably most up-to-date versions found on aros-archive!

These instead are the applications found on aros-archive that make use of stdc.library, stdcio.library, posixc.library:

wput: http://archives.a...6-aros.lha
Acidwarp: http://archives.a...6-aros.zip
Dosbox: http://archives.a...6-aros.lha

Bad Apple : http://archives.a...6-aros.lha
On Bad Apple to require the mentioned libraries is a file in the directori named "potrace", by deleting "potrace" the Bad Apple animation still works, i do not know what the 'potrace' file is for.

SCANdal: Among the programme requirements is "Jfif.library", but even if it is not present, it still works on AROS, verified with "Sashimi", no presence of the "Jfif.library" requirement

Applications using 'stdc.library, stdcio.library, posixc.library':
All "Demo Mesa"

Applications using only "stdc.library, stdcio.library"
Hostgl.library
Thread.library

Applications using only "Thread.library"
wbXcli
ArosVNC
ArosVNC-Server
ArTorr
ArmodPlugPlayer
aMP3ToWAV
FileOP
iddemon

Applications using "stdc.library
SMBFS


this report by amigasystem
A
Amiwell79Distro Maintainer
Posted 6 months ago
no i am successfully using the latest build but i have the problem with the intelGMA driver and yes the software mentioned before i.e. modexplorer, SMBFS and vnc which i currently do not use
A
Amiwell79Distro Maintainer
Posted 6 months ago
with the acer aspire A110 I could not connect to the network with the atheros driver the configuration is correct and functional but applications that make use of the network do not work
D
deadwoodAROS Dev
Posted 6 months ago
Ok, noted.
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 6 months ago
On Acer One Z5 Atheros driver works fine, I connected with OWB and AmiTube and in Radio Streaming!
A
Amiwell79Distro Maintainer
Posted 6 months ago
amigasystem my acer model is different from yours, then another thing deadwood I have connected a compatible wifi card that I have always used with other builds on an acer 5630 in this case odyssey gives me certificate error but they are up to date
A
Amiwell79Distro Maintainer
Posted 6 months ago
lan works on the acer aspire A110
A
Amiwell79Distro Maintainer
Posted 6 months ago

Amiwell79 wrote:

@Amiwell79 - [quote name=deadwood post=3385]@deadwood - Ok, noted.


I deleted the configuration file in env-archive and redid the configuration procedure now it works, ok now I have to figure out what the problem is on the acer 5630
AMIGASYSTEMAMIGASYSTEMDistro Maintainer
Posted 6 months ago
Besides On Acer One Z5 Alteros works fine for me on my Samsung R522 !

Try copying the settings from the PC that works, onto the one that doesn't!

The fie to copy are:

SYS:Env-Archive/AROSTCP (complete folder)
SYS:Env-Archive/SYS/Wireless.prefs

It concerns certificates, check OWB's settings and the path where OWB searches for them, there are different paths on which OWB searches, even the file name can change !
You can view all discussion threads in this forum.
You cannot start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You cannot download attachments in this forum.
Users who participated in discussion: serk118uk, magorium, deadwood, AMIGASYSTEM, pixie, retrofaza, Amiwell79, miker1264, Gundam
Sign In
Not a member yet? Click here to register.
Forgot Password?
Users Online Now
Guests Online 18
Members Online 1
Ilbarbax

Total Members: 235
Newest Member: pikewerfer
Member Polls
Should AROSWorld continue with AROS-Exec files (SMF based)?
Yes44 %
44% [12 Votes]
No26 %
26% [7 Votes]
Not sure30 %
30% [8 Votes]